knifflige Frage an Excelexperten

Beiträge: 23
Zugriffe: 396 / Heute: 1
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

knifflige Frage an Excelexperten

2
16.02.13 18:47
#1
im Anhang ein Screenshot dazu:

die Fälle, das RW sowie UVD, MVD und OVD sind vorgegeben. In einer Zeile darf bei UVD, MVD und OVD nur jeweils eine 1 vorkommen. Taucht also in der Summe in Spalte F eine 2 auf, dann soll diese Zeile nicht in die Endberechnung mit einfließen. Wenn also in der Spalte F eine 1 steht, dann wird RW mit UVD, MVD oder OVD multipliziert.

In G36 habe ich also in geschrieben =+wenn(c36="x";0;B36*A36)

1)was muss ich bitte schreiben, damit noch die Spalte F Beachtung findet? Wenn dort also eine 2 steht, dann das Ergebnis 0 sein soll

2) wie muss ich mit dem Funktionsassistenten schreiben, wenn ich mir die Spalten G, H und I sparen möchte und direkt die Ergebnisse in C45,46 und 47 sowie in D45,46,47 haben möchte.
(Verkleinert auf 53%) vergrößern
knifflige Frage an Excelexperten 579413
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

ganz einfach

 
16.02.13 19:11
#2
(Verkleinert auf 81%) vergrößern
knifflige Frage an Excelexperten 579415
knifflige Frage an Excelexperten Geldbert
Geldbert:

die schlausten zu zweit, übertreffen die erwartung

3
16.02.13 19:13
#3
knifflige Frage an Excelexperten Geldbert
Geldbert:

ich werde nun ausgegrenzt

2
16.02.13 19:13
#4
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

#1

 
16.02.13 19:18
#5
1)was muss ich bitte schreiben, damit noch die Spalte F Beachtung findet? Wenn dort also eine 2 steht, dann das Ergebnis 0 sein soll

-welches Ergebnis ( von welche Zelle )?
knifflige Frage an Excelexperten Crossboy
Crossboy:

@1: Excel wird als Miittel um Frauen aufzureißen

2
16.02.13 19:19
#6
überbewertet...
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

#5

 
16.02.13 19:26
#7
in deiner excel tabelle darf in der Spalte G nur eine 1 stehen, sobad eine 2 oder 3 dort steht, dann darf die ganze Spalte nicht in die Endberechnung miteinfließen. In deiner Tabelle also die komplette Zeile 6 (433 Fälle, 8,2 BW usw.). Das muss also noch in die Formel rein.
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

xx

 
16.02.13 19:33
#8
(Verkleinert auf 62%) vergrößern
knifflige Frage an Excelexperten 579419
Der ARIVA.DE Newsletter
Bleiben Sie informiert mit dem
wöchentlichen Marktüberblick
von ARIVA.DE!
E-Mail-Adresse
Ich möchte Benachrichtigungen von ARIVA.DE erhalten.
Ja, ich habe die Datenschutzhinweise gelesen und akzeptiert (Pflichtfeld).
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

#5 Formel von #2 bezügl. Wunsch 1 geändert

 
16.02.13 19:47
#9
(Verkleinert auf 52%) vergrößern
knifflige Frage an Excelexperten 579421
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

Darauf ein Bier und Schöö

 
16.02.13 19:49
#10
knifflige Frage an Excelexperten Geldbert
Geldbert:

bleiben sie bitte sitzen

 
16.02.13 19:50
#11
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

geprüft

 
16.02.13 19:54
#12
(Verkleinert auf 51%) vergrößern
knifflige Frage an Excelexperten 579423
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

nu ist gut, Geldbert geh an die frische Luft

 
16.02.13 19:55
#13
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

ne, das haut noch nicht hin

 
16.02.13 20:25
#14
da zum einen die Werte in den Spalten D, E und F jederzeit verändert werden können.

Ich versuche es nochmal zu erklären, weil ich vergessen hatte zu erwähnen, dass ungefähr 1000 Fälle untereinanderstehen..also nach 500,260,310 und 433 kommen noch gut 1000 Stück. Es sollen also überall da, wo eine 1 steht, die werte in B und c multipliziert werden und dann zum schluss eine Summe ergeben. Es darf aber nur multiplziert werden, wenn nur eine 1 pro Zeile steht. Wenn bei G also eine 2 herauskommt, dann kommt das nicht in die Endberechnung.

Da muss also stehen je Zeile: wenn in C3 eine 1 steht und in F3 keine 2 (oder mehr als 1), dann soll A3 mit B3 multipliziert werden. Wenn D3 eine 1 und in F3 kein Wert über 1, dann soll A3 mit B3 multipliziert werden usw. Und das dann Zeile für Zeile.
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

das muss mit dem Funktionsassistenten

 
16.02.13 20:40
#15
funktionieren!
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

#14 so ist es in 12 realisiert

 
16.02.13 20:51
#16
Problem ist die Summenbildung bei 1000 Zeilen ( 256 Zeichen pro Anweisung ist glaube ich das Limit ). Da wäre es besser die 3 Spalten für die Einzelergebnisse zu nutzen und unsichtbar zu machen (oder 10 Spalten weiter rechts o.ä.)  und dann die Summe der 3 Spalten zu bilden.

Tipp: noch eleganter ist es mit einem Button und einem vba Programm
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

ja, diese G Spalte macht alles so kompliziert

 
16.02.13 20:55
#17
kannst du bitte mal in deinem #12 Post bei F3 ein x hinmachen und bei D3 eine 1 und dann gucken,  ob es noch immer funktioniert. Meiner Meinung nämlich nicht.
knifflige Frage an Excelexperten Geldbert
Geldbert:

stehen sie nicht auf, sonst werden sie gesperrt

 
16.02.13 21:20
#18
knifflige Frage an Excelexperten Cliff Fiscal
Cliff Fiscal:

#17 na klar

 
16.02.13 21:24
#19
(Verkleinert auf 73%) vergrößern
knifflige Frage an Excelexperten 579453
knifflige Frage an Excelexperten Pest-and-Cholera
Pest-and-Chol.:

Eure Probleme will ich haben

 
16.02.13 21:25
#20
geil, hahaha
knifflige Frage an Excelexperten obgicou
obgicou:

wann kommt denn nun

 
16.02.13 21:43
#21
die knifflige Frage?
knifflige Frage an Excelexperten Päfke Müller
Päfke Müller:

#19

 
16.02.13 22:37
#22
ich schaus mir morgen an..danke soweit für deine Hilfe!
knifflige Frage an Excelexperten Cliff Fiscal

in BM geht es nicht daher hier

 
#23
Wenn in Spalte B von Zeile 5 bis 50 die Alterszahlen stehen und in B1 ( von ) und in B2 ( bis )

=ZÄHLENWENN(B5:B50;UND(B5>=B$1;B5<=B$2))"

d.h. Zähle wie oft in Zelle B5 bis B50 eine Alterseingabe steht die größer gleich der Zahl in Feld B1 ist und die kleiner gleich der Zahl in B2 ist.

Wenn du in C1 und C2 einen zweiten Bereich angibts dann
=ZÄHLENWENN(B5:B50;UND(B5>=C$1;B5<=C$2))"

Gruss


Talkforum - Gesamtforum - Antwort einfügen - zum ersten Beitrag springen
--button_text--